Folgende Funktion: =SUMMENPRODUKT(1/ZÄHLENWENN(A2:A20;A2;A20)) ermittelt die Anzahl der verschiedenen Werte einer Liste. Voraussetzung: A20 ist der letzte Eintrag der Liste. Sie darf keine Leerzellen enthalten.
Ansonsten muss man mit einer Matrixfunktion arbeiten und diese Zellen mit einer WENN()-Funktion „abfangen“.